Problemas al ejecutar script en netlogon.

Todo sobre los distintos SSOO de Windows

Moderador: Moderadores

Problemas al ejecutar script en netlogon.

Notapor xaky » Vie Feb 08, 2013 10:34 am

Buenas.

Tengo dos controladores de dominio, uno de ellos también lo uso como servidor DHCP.

Al iniciar sesión, los equipos ejecutan un script ubicado en el directorio netlogon de unos de los DC, el problema es que desde hace un tiempo algunos equipos( dependiendo de la rapidez del usuario en iniciar sesión) no ejecutan el script, ya que cuando intentan ejecutarlo aún no han recibido la ip del servidor dhcp y claro al no tener ip pues no pueden ejecutar el script que hay en netlogon.

Sabéis si hay alguna manera de retrasar la ejecución de ese script, o posibles motivos de la lentitud al recibir ips, la lentitud la verdad no es mucha en un par de segundos después de iniciar sesión ya han recibido la ip, pero si el usuario es rápido iniciando sesión no me vale!!!

Un Saludo y gracias por adelantado!!
xaky
:-)
:-)
 
Mensajes: 5
Registrado: Mié Abr 12, 2006 11:48 am

Re: Problemas al ejecutar script en netlogon.

Notapor Bebbop » Vie Feb 08, 2013 11:24 am

Lo que te sucede es bastante raro...
Algo raro tienes entre con el DHCP porque cuando una maquina te pide las credenciales ya deberías tener IP o eso o tienes algún problema en los clientes que hace la gestión de redes vaya mal.

No recuerdo que exista ninguna GPO que retrase la ejecución de un script de Netlogon, es que justamente la ejecución del script del netlogon es esa... ejecutarlo después de hacer logon.

Yo me enfocaría más en saber porque tienes esa situación de hacer logon sin IP estando en la LAN que no en mirar de retrasar la ejecución del script, no es normal.
Avatar de Usuario
Bebbop
Gran Wadalbertita
Gran Wadalbertita
 
Mensajes: 3424
Registrado: Mié Dic 14, 2005 2:46 pm
Ubicación: El Inframundo

Re: Problemas al ejecutar script en netlogon.

Notapor xaky » Vie Feb 08, 2013 12:48 pm

Hola Bebbop gracias.

La verdad es que si que es raro, no me había pasado nunca.., estoy pensando en igual cambiar el servidor de dhcp a otra máquina, también he leído que podría ser que el spanning tree en los switchs podría ser una causa de la lentitud al recibir las ips, haré algunas pruebas sobre esto y con wireshark a ver si averiguo algo.

Lo de retrasar la ejecución del script era solo para solucionarlo temporalmente mientras no doy con el motivo del problema.


Un Saludo
xaky
:-)
:-)
 
Mensajes: 5
Registrado: Mié Abr 12, 2006 11:48 am

Re: Problemas al ejecutar script en netlogon.

Notapor xaky » Vie Feb 08, 2013 1:26 pm

Buenas.

Acabo de configurar el dhcp en el otro DC, he probado con una maquina cliente y el problema continua.

He probado con perfmon si veía algo raro y de momento no he visto nada, enfocaré el tema hacía el switching, no sea que vaya por allí.

Si se os ocurre algo, agradecería cualquier comentario.

Gracias y un Saludo
xaky
:-)
:-)
 
Mensajes: 5
Registrado: Mié Abr 12, 2006 11:48 am

Re: Problemas al ejecutar script en netlogon.

Notapor hilbert69 » Dom Feb 10, 2013 2:00 pm

Hola xaky.Es posible que sea un problema de Spanning-Tree... ¿que switches estás utilizando en la red? En principio en los switches gestionables lo normal es que en los puertos donde tengas conectados dispositivos finales habilites "spanning-tree port-fast", esto hace que ese puerto pase automáticamente al estado de "forwarding", es decir no espere a que spanning-tree le permita enviar y recibir tramas de datos. Por defecto con Spanning-Tree tradicional (802.3D) los puertos tardan unos 50 seg en estar operativos totalmente.
Un saludo.
hilbert69
:-)
:-)
 
Mensajes: 17
Registrado: Lun Dic 01, 2008 10:58 pm

Re: Problemas al ejecutar script en netlogon.

Notapor Newhack » Dom Feb 10, 2013 9:00 pm

A lo mejor digo una tonteria, porque esto no es lo mio, pero mientras buscas el problema ¿no se podría hacer una especie de "semaforo" de pega?,
me refiero a que antes de ejecutar el script tenga que atender otro de mas prioridad o puesto antes o lo que sea, que pida una ip válida, (del serv. dhcp).
Hasta que la ip no sea del rango y tipo correcto no termina y por tanto el siguiente script ha de esperar. ;)

Es un poco chapuzas, pero es para mientras buscas la causa primera del problema.
Avatar de Usuario
Newhack
<|:-D
<|:-D
 
Mensajes: 1864
Registrado: Jue Dic 20, 2007 7:36 pm

Re: Problemas al ejecutar script en netlogon.

Notapor xaky » Lun Feb 11, 2013 1:28 pm

Buenas.

Ya di con el problema, cómo ya pensaba y cómo bien apuntó hilbert69 el problema era el spanning tree, pero ya tenia el "spanning-tree port-fast" activado, los switchs que tengo son allied telesis, al final he tenido activar el "edge port" en el spanning tree de los puertos donde están los clientes conectados y solo dejar el spanning tree sin el "edge port" en los puertos de switch a switch, curiosamente solo he tenido que hacerlo en los nuevos switchs que añadimos a la red, supongo que al ser más modernos pues algo habrán cambiado, en los antiguos switch, también allied, nunca me ha hecho falta hacerlo.

Newhack ya no he probado lo que comentas porqué ya di con el problema, muchas gracias igualmente.


Un Saludo y gracias otra vez!!!
xaky
:-)
:-)
 
Mensajes: 5
Registrado: Mié Abr 12, 2006 11:48 am


Volver a Windows

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 3 invitados

cron